Property Management Software Support - Console Instructions for PIM


Great news! Data sharing between Console and Property Inspection Manager is available for PIM Premium users. If you are not using the latest PIM version or would like to upgrade your account to PIM Premium, contact support. You can import data including Owner and Tenant details, Next Inspection Date and Lease Details (including Start and End Dates). 


These instructions have been confirmed to be working in Console and v6.* and v7.*.


AUGUST 2017 UPDATE - We have updated the Console GUR file that is used for processing to fix some mapping issues regarding owner & tenant emails and phone numbers. Owner email and phone data can no longer be processed unfortunately. Please download a new GUR file below and save into the CONSOLE (follow STEP 2 in First Time Set Up).


Importing from Console into PIM involves an initial First Time Set Up then three stages;

(1) Export properties from Console.

(2) Upload the file (CSV) to your PIM online account.

(3) Import files into PIM on the iPad.


First Time Set Up (You only need to do this once)


If using Console with PIM for the first time, you will need to set up your Console Report Files and Inspection Views.  If you have already done this before, jump to the next stage of Exporting properties


Step 1: Open Console and select Tools > Options. Click the Folders tab.  You should be presented with a screen similar to the one shown below.  Look at the User Reports (1) location and make a note of this for later.  (yours may be different to the one in our image)Click OK to dismiss this window.



Step 2: Download the PIM Console Inspections Import.gur file by right clicking on this link and choose 'Save Link As'. Save the gur file into your User Reports location, as per Step 1. Make sure the saved file has the file extension is GUR (not XML). Rename the file extension if needed. (Note: You may need to be logged in as a Console Administrator on your PC, so check with others in your office if you are having trouble copying the User Reports file).   


Step 3: Next you need to set up a suitable Inspection View to export all your property information including Next Inspection Dates, if one does not exist. From the top menu go to Views > Goto > Inspections. If there is already a view called Inspections (Gateway 2007) or if you know of an Inspection View which contains an active and valid list of Inspections (including Active Tenants) for your Properties in Console then select that one and just jump ahead to Stage 2 (Exporting Properties). If you don't have one, then keep going to the next step below.


Step 4:  From the View menu select Current View then Define Views 


Step 5: Select New then type 'Incomplete Routine Inspections for Active Tenants' as the View name, then select OK. 


Step 6: Select the Filter button, then select the SQL tab, then select Edit these criteria directly.


Step 7: Copy the text below, and Paste it onto the SQL tab.

where completed is null and [Type] Like '%Routine%' and tenantid in (select id from tenants where inactive = 0) 


Step 8: Select OK and then ensure the recently created View (1) is highlighted in the Define Views window. Select the Set Current (2) button then select Close


You are now ready to proceed with the next Export Properties stage.



(1) Export Properties From Console


Please ensure you have previously completed the First Time Set Up (above) to set up Console Report Files and Inspection Views.   If these are already in place, you can continue with the data export.


Step 1: In Console, under the main menu click Edit then Select All.  Click on Inspections.  Then from the top menu click File then Folder and Print.


Step 2: On the window displayed, ensure the check box Preview (1) is ticked, as this will generate a file for Preview rather than print the report). Also ensure that in the section titled Report, User Report (2) is selected and then select OK.



Step 3: Select PIM Console Inspections Import (1)  and click OK and then wait for the report to generate.


Step 4: The report will now appear on your screen. This can take several minutes to generate if you have a large number of properties in Console. Click on Export to File (1) icon located next to the Export to Email icon at the top of screen. 



Step 5: In the export window, choose Comma-Separated values (CSV)  and select OK.



Step 6: When prompted save the file to a location on your computer hard drive (e.g your PC's C:\Drive or local Desktop.) using a file name such as PIM Console Inspections Import.csv. Make sure Save as Type is is Comma Separated values (*.csv) (1) before selecting Save (2). 



(Note: if you are in a large office and you are exporting an individual property manager's inspections you may like to prefix your file with an initials, i.e. PG-PIM Console Inspections Import.csv, and/or when the export was performed i.e PG-PIM Console Inspections Import-11062015.csv which shows the file was exported on 11th June 2015. This may help when you need to perform future exports and also distinguish your import files for the Import Stage. Make a note of the location where you saved the file.


Step 7: Check to make sure the file has been saved in the drive before moving on tho the Upload stage below.



(3) Upload CSV File to Your PIM Online Account


The next step is to upload the CSV file to your PIM online account in order for you to download onto the PIM App on your iPad later.


Step 1: Visit www.propertyinspectionmanager.com and click the SIGN UP/LOGIN button in the top right corner.


Step 2: Enter the Email and Password linked to your PIM Premium account.



Step 3: Once logged in, click the Import Files tab.



Step 4: Select the correct Console version from the Product/Version options, then click Choose File to locate and select the previously saved CSV file from your computer.  Once done click Upload File.


Step 5: A "File Upload Successful" message will appear in green text box above the File table.


(Handy Hint: If an error appears saying ‘File Already Exists’ you will need to rename the file so that it has a different file name or simply delete the previous file in your account and upload again. Alternatively, try renaming the file by incorporating today's date into the filename  i.e. PIM Inspections Import-22062015.csv.



(3) Import Files Into PIM On The iPad


The final stage of the import is to import the property data to PIM on your iPad. Make sure you have followed Stages (1) and (2). Remember that the import function is only available for PIM Premium accounts.


Step 1: Check the following in PIM to make sure your data import goes smoothly;

  • Check the Default Inspector is at the top of your inspectors list via Settings > PIM Admin > Inspectors. The PIM app will automatically associate the default Property Manager/Inspector in PIM against new Properties imported. To change the Default Inspector simply click Edit and then using the small bars move the desired Inspector to the top position and then click Done to save. The new Default Inspector is now ready !!.
  • Select your Default Property Profile for Import and check all the Inspection Areas you need are included via Settings > PIM Admin > Property Profiles. A Property Profile is a best fit or average layout for your Properties or Inspections (including custom callouts i.e. Maintenance Required/Suggested Improvements). We suggest that if the Property Profile say has 3 Bedrooms and then for a specific Inspection if there are only 2 bedrooms, it’s quicker to delete the extra bedroom than adding a bedroom. 
  • Check out -  Setting up Property Profiles in PIM if you need more assistance. Configuring Property Profiles can be done in the PIM app via Settings > PIM Admin > Property Profiles
  • Set the correct Inspection Type via Settings > PIM Admin > Inspection Type. Note the default Inspection Type is Inspection Report. 
  • Set 'Quick Check Always Ticked' in Settings > PIM Admin if you require all quick check labels to be automatically ticked 'on'.
  • Make sure your iPad is in horizontal mode rather than landscape.


Step 2: Tap the Import tab at the bottom of the PIM screen.

 


Step 3: Once in the Import screen, tap Import Data in the top left corner.


Step 4: Tap the Refresh Icon (the circular arrow) in the bottom left corner then OK in the pop-up window to start the download.


Step 5: Tap on the latest data file.

Step 6: Use the toggles to select New Properties (1) or Existing Properties With Updated Info (2).  Properties available for import will be displayed at the bottom of the screen.  You can tap to select specific properties or select all.

  • New properties are those properties that have not previously been imported into PIM.
  • Updated properties are those previously imported properties that contain updated information from Property Tree and contain a newer Inspection Date. When importing updated properties, PIM will automatically perform a 'Repeat Inspection' on these selected properties and a new Inspection will be created with updated Inspection Dates and include related updated tenancy data. The previous Inspection Area layout is preserved and any history notes are associated with that Inspection. We never update existing Inspections for safety and auditing reasons and to preserve the history of that Inspection in the app.
  • To filter only properties assigned to yourself or the default Inspector toggle Show Only Default Inspector.


Step 7: Tap the Action Icon (1) in the top right, then Import All or Import Selected (2) as required.

 


Step 8: Tap Continue to create a new inspection template based on the default Property Profile, or tap one of the other Profile options.


Step 9: Tap OK to confirm successful import.


Step 10: Your new inspections will now be displayed in the Inspection List from the Inspections Tab.  Go ahead and complete the inspection in the usual way by adding notes and photos.  Remember you will need to Submit your inspection at the end.




Any problems or questions please contact PIM Support.